Dual ISP Failover on Cisco Router
Fig 1: Dual ISP Failover |
Dual ISP Failover on Cisco Router Configurations
!
interface GigabitEthernet0/2
description Secondary-WAN
ip address x.x.x.x x.x.x.x
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
description Primary-WAN
ip address x.x.x.x x.x.x.x
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/0
description LAN-Side
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.160
description LAN-Phase
encapsulation dot1Q 160
ip address 172.16.23.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.260
encapsulation dot1Q 260
ip address 172.16.24.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip policy route-map SEC
!
no ip http server
no ip http secure-server
!
track 8 ip sla 1 reachability
!
ip sla 1
icmp-echo x.x.x.x source-ip x.x.x.x
ip sla schedule 1 life forever start-time now
!
ip nat inside source route-map SEC interface GigabitEthernet0/2 overload
ip nat inside source route-map PRI interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 x.x.x.x track 8
ip route 0.0.0.0 0.0.0.0 x.x.x.x 10
ip route 0.0.0.0 0.0.0.0 x.x.x.x name Secondary
ip route 0.0.0.0 0.0.0.0 x.x.x.x name Primary
!
access-list 100 permit ip 172.16.24.0 0.0.0.255 any
route-map SEC permit 10
match ip address 100
match interface GigabitEthernet0/2
set ip default next-hop x.x.x.x
!
access-list 101 permit ip 172.16.23.0 0.0.0.255 any
route-map PRI permit 10
match ip address 101
match interface GigabitEthernet0/1
set ip default next-hop x.x.x.x
!
control-plane
!
end
0 Comments