OSPF Multi Area Lab

OSPF Multi Area Lab



OSPF Multi Area Lab
Fig 1: OSPF Multi Area Lab


About Topology

OSPF Multiarea Lab
Fig 2: OSPF Multiarea Lab Topology
In the above diagram we have a lab in which there are multiples areas. Area 0 is the backbone area there are 4 others areas that are directly connected to the backbone area. All the routers of the other areas except area 0 have the loopbacks. Router 1 and 2 are the cores routers. Router 3,4,5 and 6 are the distribution layer routers and the others routers are the access layer routers. Loopbacks will be configured as the router ID. Following are the points of this lab that we have to cover:
  • Multiarea OSPF Lab
  • Loopback must be configured as router ID
  • Perform Convergence 

Configurations

Router 1's  Configurations

!
hostname Core-1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
interface FastEthernet0/0
 ip address 200.200.200.1 255.255.255.252
 duplex auto
 speed auto
 no keepalive
!
interface Serial0/0
 ip address 9.9.9.1 255.255.255.252
 no fair-queue
 clock rate 2000000
!
interface Serial0/1
 ip address 10.10.10.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/2
 ip address 11.11.11.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/3
 ip address 12.12.12.1 255.255.255.252
 clock rate 2000000
!
router ospf 10
 log-adjacency-changes
 network 9.9.9.1 0.0.0.0 area 0
 network 10.10.10.1 0.0.0.0 area 0
 network 11.11.11.1 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0
 network 200.200.200.1 0.0.0.0 area 0
!
ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Router 2's  Configurations

!
hostname Core-2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
interface FastEthernet0/0
 ip address 200.200.200.2 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 13.13.13.1 255.255.255.252
 no fair-queue
 clock rate 2000000
!
interface Serial0/1
 ip address 14.14.14.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/2
 ip address 15.15.15.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/3
 ip address 16.16.16.1 255.255.255.252
 clock rate 2000000
!
router ospf 10
 log-adjacency-changes
 network 13.13.13.1 0.0.0.0 area 0
 network 14.14.14.1 0.0.0.0 area 0
 network 15.15.15.1 0.0.0.0 area 0
 network 16.16.16.1 0.0.0.0 area 0
 network 200.200.200.2 0.0.0.0 area 0
!
!
ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Router 3's  Configurations

!
hostname Distribution-3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
interface Serial0/0
 ip address 12.12.12.2 255.255.255.252
 no fair-queue
 clock rate 2000000
!
interface Serial0/1
 ip address 14.14.14.2 255.255.255.252
 clock rate 2000000
!
interface Serial0/2
 ip address 8.8.8.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/3
 ip address 7.7.7.1 255.255.255.252
 clock rate 2000000
!
router ospf 10
 log-adjacency-changes
 network 7.7.7.1 0.0.0.0 area 4
 network 8.8.8.1 0.0.0.0 area 4
 network 12.12.12.2 0.0.0.0 area 0
 network 14.14.14.2 0.0.0.0 area 0
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Router 4's  Configurations

!
hostname Distribution-4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
interface Serial0/0
 ip address 11.11.11.2 255.255.255.252
 no fair-queue
 clock rate 2000000
!
interface Serial0/1
 ip address 15.15.15.2 255.255.255.252
 clock rate 2000000
!
interface Serial0/2
 ip address 6.6.6.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/3
 ip address 5.5.5.1 255.255.255.252
 clock rate 2000000
!
router ospf 10
 log-adjacency-changes
 network 5.5.5.1 0.0.0.0 area 3
 network 6.6.6.1 0.0.0.0 area 3
 network 11.11.11.2 0.0.0.0 area 0
 network 15.15.15.2 0.0.0.0 area 0
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Router 5's  Configurations

!
hostname Distribution-5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
interface Serial0/0
 ip address 9.9.9.2 255.255.255.252
 no fair-queue
 clock rate 2000000
!
interface Serial0/1
 ip address 13.13.13.2 255.255.255.252
 clock rate 2000000
!
interface Serial0/2
 ip address 1.1.1.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/3
 ip address 2.2.2.1 255.255.255.252
 clock rate 2000000
!
router ospf 10
 log-adjacency-changes
 network  1.1.1.1 0.0.0.0 area 1
 network  2.2.2.1 0.0.0.0 area 1
 network 9.9.9.2 0.0.0.0 area 0
 network 13.13.13.2 0.0.0.0 area 0
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Router 6's  Configurations

!
hostname Distribution-6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
interface Serial0/0
 ip address 10.10.10.2 255.255.255.252
 no fair-queue
 clock rate 2000000
!
interface Serial0/1
 ip address 16.16.16.2 255.255.255.252
 clock rate 2000000
!
interface Serial0/2
 ip address 3.3.3.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/3
 ip address 4.4.4.1 255.255.255.252
 clock rate 2000000
!
router ospf 10
 log-adjacency-changes
 network 3.3.3.1 0.0.0.0 area 2
 network 4.4.4.1 0.0.0.0 area 2
 network 10.10.10.2 0.0.0.0 area 0
 network 16.16.16.2 0.0.0.0 area 0
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Router 7's  Configurations

!
hostname Access-7
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
interface Loopback0
 ip address 102.102.102.102 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.8.100 255.255.255.0
 duplex auto
 speed auto
 no keepalive
!
interface Serial0/0
 ip address 8.8.8.2 255.255.255.252
 no fair-queue
 clock rate 2000000
!
router ospf 10
 router-id 102.102.102.102
 log-adjacency-changes
 network 8.8.8.2 0.0.0.0 area 4
 network 102.102.102.102 0.0.0.0 area 4
 network 192.168.8.100 0.0.0.0 area 4
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Router 8's  Configurations

!
hostname Access-8
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
interface Loopback0
 ip address 101.101.101.101 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.7.100 255.255.255.0
 duplex auto
 speed auto
 no keepalive
!
interface Serial0/0
 ip address 7.7.7.2 255.255.255.252
 no fair-queue
 clock rate 2000000
!
router ospf 10
 router-id 101.101.101.101
 log-adjacency-changes
 network 7.7.7.2 0.0.0.0 area 4
 network 101.101.101.101 0.0.0.0 area 4
 network 192.168.7.100 0.0.0.0 area 4
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Router 9's  Configurations

!
hostname Access-9
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
interface Loopback0
 ip address 100.100.100.100 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.6.100 255.255.255.0
 duplex auto
 speed auto
 no keepalive
!
interface Serial0/0
 ip address 6.6.6.2 255.255.255.252
 no fair-queue
 clock rate 2000000
!
!
router ospf 10
 router-id 100.100.100.100
 log-adjacency-changes
 network 6.6.6.2 0.0.0.0 area 3
 network 100.100.100.100 0.0.0.0 area 3
 network 192.168.6.100 0.0.0.0 area 3
!
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Router 10's  Configurations

!
hostname Access-10
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
interface Loopback0
 ip address 90.90.90.90 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.5.100 255.255.255.0
 duplex auto
 speed auto
 no keepalive
!
interface Serial0/0
 ip address 5.5.5.2 255.255.255.252
 no fair-queue
 clock rate 2000000
!
!
router ospf 10
 router-id 90.90.90.90
 log-adjacency-changes
 network 5.5.5.2 0.0.0.0 area 3
 network 90.90.90.90 0.0.0.0 area 3
 network 192.168.5.100 0.0.0.0 area 3
!
!
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Router 11's  Configurations

!
hostname Access-11
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
interface Loopback0
 ip address 50.50.50.50 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.100 255.255.255.0
 duplex auto
 speed auto
 no keepalive
!
interface Serial0/0
 ip address 1.1.1.2 255.255.255.252
 no fair-queue
 clock rate 2000000
!
router ospf 10
 router-id 50.50.50.50
 log-adjacency-changes
 network 1.1.1.2 0.0.0.0 area 1
 network 50.50.50.50 0.0.0.0 area 1
 network 192.168.1.100 0.0.0.0 area 1
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Router 12's  Configurations

!
hostname Access-12
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
interface Loopback0
 ip address 60.60.60.60 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.2.100 255.255.255.0
 duplex auto
 speed auto
 no keepalive
!
interface Serial0/0
 ip address 2.2.2.2 255.255.255.252
 no fair-queue
 clock rate 2000000
!
router ospf 10
 router-id 60.60.60.60
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 1
 network 60.60.60.60 0.0.0.0 area 1
 network 192.168.2.100 0.0.0.0 area 1
!
!
!
ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Router 13's  Configurations

!
hostname Access-13
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
interface Loopback0
 ip address 70.70.70.70 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.3.100 255.255.255.0
 duplex auto
 speed auto
 no keepalive
!
interface Serial0/0
 ip address 3.3.3.2 255.255.255.252
 no fair-queue
 clock rate 2000000
!
!
router ospf 10
 router-id 70.70.70.70
 log-adjacency-changes
 network 3.3.3.2 0.0.0.0 area 2
 network 70.70.70.70 0.0.0.0 area 2
 network 192.168.3.100 0.0.0.0 area 2
!
!
!
ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Router 14's  Configurations
!
hostname Access-14
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
interface Loopback0
 ip address 80.80.80.80 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.4.100 255.255.255.0
 duplex auto
 speed auto
 no keepalive
!
interface Serial0/0
 ip address 4.4.4.2 255.255.255.252
 no fair-queue
 clock rate 2000000
!
!
router ospf 10
 router-id 80.80.80.80
 log-adjacency-changes
 network 4.4.4.2 0.0.0.0 area 2
 network 80.80.80.80 0.0.0.0 area 2
 network 192.168.4.100 0.0.0.0 area 2
!
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Post a Comment

0 Comments