Border Gateway Protocol Basic Lab

BGP Basic Lab



Border Gateway Protocol Basic Lab
Fig 1 : Border Gateway Protocol Basic Lab

About Topology

Border Gateway Protocol Basic Lab
Fig 2: BGP Basic Lab Topology
In the above diagram we have we have two routers router 1 and router 2 and in between the two routers we have a network 1.0.0.0/8. Suppose we have two autonomous system and we configure the Border Gateway Protocol and that is the External Border Gateway Protocol and we will establish the neighbor ship with the loopbacks of the routers forcefully.

Configurations

Router 1's Configurations

!
hostname AS-1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
interface Loopback0
 ip address 11.11.11.11 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.1.100 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 1.1.1.1 255.0.0.0
 no fair-queue
 clock rate 2000000
!
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 11.11.11.0
 network 192.168.1.0
 neighbor 12.12.12.12 remote-as 2
 neighbor 12.12.12.12 ebgp-multihop 2
 neighbor 12.12.12.12 update-source Loopback0
 no auto-summary
!
ip route 12.12.12.0 255.255.255.0 1.1.1.2
!
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end


Router 2's Configurations

!
hostname AS-2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
interface Loopback0
 ip address 12.12.12.12 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.2.100 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 1.1.1.2 255.0.0.0
 no fair-queue
 clock rate 2000000
!
router bgp 2
 no synchronization
 bgp log-neighbor-changes
 network 12.12.12.0
 network 192.168.2.0
 neighbor 11.11.11.11 remote-as 1
 neighbor 11.11.11.11 ebgp-multihop 2
 neighbor 11.11.11.11 update-source Loopback0
 no auto-summary
!
ip route 11.11.11.0 255.255.255.0 1.1.1.1
!
!
ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end



Post a Comment

0 Comments